aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index 98ac3c3..0a5ad82 100644
--- a/default.nix
+++ b/default.nix
@@ -33,15 +33,10 @@ in rec {
});
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
- buildInputs = [ jekyllEnv pkgs.html-tidy pkgs.moreutils ];
+ buildInputs = [ jekyllEnv ];
buildPhase = ''
patchShebangs .
jekyll build -d $out
- ./scripts/tidy-content.sh $out || {
- echo 'Error in formatting HTML. Reproduce with: '
- echo ' jekyll build && ./scripts/tidy-content.sh _site/'
- exit 1
- }
'';
});
};
@@ -58,8 +53,6 @@ in rec {
buildInputs = [
jekyllEnv
(pkgs.hunspellWithDicts (with pkgs.hunspellDicts; [ en-us ]))
- pkgs.html-tidy
- pkgs.moreutils
];
};
publishScript = utils.overwritingPublishScript {