aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2020-08-05 18:24:33 -0300
committerEuAndreh <eu@euandre.org>2020-08-05 18:24:33 -0300
commitaf70656ad80b56f5ef263b6f23c4580dab06cd78 (patch)
tree9282abda6746c93b6ba7868d56222beb74394cdb /default.nix
parentUse tidy to format HTML (diff)
downloadeuandre.org-af70656ad80b56f5ef263b6f23c4580dab06cd78.tar.gz
euandre.org-af70656ad80b56f5ef263b6f23c4580dab06cd78.tar.xz
Remove HTML Tidy step
It conflicts with rouge, and changes the visualization of the final HTML. So I can look at a CSS locally served by 'jekyll serve' but in the end final output is different.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index 98ac3c3..0a5ad82 100644
--- a/default.nix
+++ b/default.nix
@@ -33,15 +33,10 @@ in rec {
});
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
- buildInputs = [ jekyllEnv pkgs.html-tidy pkgs.moreutils ];
+ buildInputs = [ jekyllEnv ];
buildPhase = ''
patchShebangs .
jekyll build -d $out
- ./scripts/tidy-content.sh $out || {
- echo 'Error in formatting HTML. Reproduce with: '
- echo ' jekyll build && ./scripts/tidy-content.sh _site/'
- exit 1
- }
'';
});
};
@@ -58,8 +53,6 @@ in rec {
buildInputs = [
jekyllEnv
(pkgs.hunspellWithDicts (with pkgs.hunspellDicts; [ en-us ]))
- pkgs.html-tidy
- pkgs.moreutils
];
};
publishScript = utils.overwritingPublishScript {