aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 7b6e001..8cd6397 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,7 @@
let
pkgs = import <nixpkgs> { };
rootSrc = pkgs.nix-gitignore.gitignoreSource [ ] ./.;
-in with pkgs;
-with pkgs.stdenv; rec {
+in rec {
utils = import ./nixos/utils.nix {
pkgs = pkgs;
rootSrc = rootSrc; # FIXME: remove the need for this
@@ -11,8 +10,7 @@ with pkgs.stdenv; rec {
test = utils.test [
utils.formatNix
(utils.shellcheck ".*(encrypted|os-installation.sh).*")
- # subtasks.fixme
+ (utils.fixme [ "default.nix" "utils.nix" ])
# subtasks.uniqueFeeds
- # subtasks.formatNix
];
}