aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2019-05-30 23:11:07 -0300
committerEuAndreh <eu@euandre.org>2019-05-30 23:11:07 -0300
commite215d02457b5eb850109d43ab577c9e994fcbe7f (patch)
treec08a264de7a2d58d1563819a0e1a28ec948fd887 /default.nix
parentMove shellCheck derivation to utils.nix (diff)
downloaddotfiles-e215d02457b5eb850109d43ab577c9e994fcbe7f.tar.gz
dotfiles-e215d02457b5eb850109d43ab577c9e994fcbe7f.tar.xz
Polish and use utils.fixme derivation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 7b6e001..8cd6397 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,7 @@
let
pkgs = import <nixpkgs> { };
rootSrc = pkgs.nix-gitignore.gitignoreSource [ ] ./.;
-in with pkgs;
-with pkgs.stdenv; rec {
+in rec {
utils = import ./nixos/utils.nix {
pkgs = pkgs;
rootSrc = rootSrc; # FIXME: remove the need for this
@@ -11,8 +10,7 @@ with pkgs.stdenv; rec {
test = utils.test [
utils.formatNix
(utils.shellcheck ".*(encrypted|os-installation.sh).*")
- # subtasks.fixme
+ (utils.fixme [ "default.nix" "utils.nix" ])
# subtasks.uniqueFeeds
- # subtasks.formatNix
];
}