aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..2ba7b07
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,44 @@
+{ pkgs, stdenv, fetchurl, lib }:
+self: super:
+let
+ default-derivation = { pname, version-prefix, version, sha256 }:
+ stdenv.mkDerivation rec {
+ inherit pname version;
+
+ src = fetchTarball {
+ url =
+ "https://git.euandreh.xyz/${pname}/snapshot/${pname}-${version-prefix}${version}.tar.gz";
+ inherit sha256;
+ };
+ makeFlags = [
+ # This shouldn't be necessary, but
+ # the `stdenv.mkDerivation' environment doesn't provide a c99 variable
+ "CC=cc"
+ ];
+
+ meta = with lib; {
+ description = readFile "${src}/description";
+ longDescription = readFile "${src}/long-description";
+ homepage = "https://${pname}.euandreh.xyz";
+ changelog = "https://${pname}.euandreh.xyz/CHANGELOG.html";
+ downloadPage = "https://${pname}.euandreh.xyz/#releases";
+ license = licenses.agpl3;
+ platforms = platforms.unix;
+ };
+ };
+in {
+ xyz-euandreh = {
+ remembering = default-derivation {
+ pname = "remembering";
+ version-prefix = "";
+ version = "cca66c6f53e8bce857faae88368c0b07e6ace9e1";
+ sha256 = "0bpm73hvpk6x3vs2lkp0kjnfdyb5hq3spl0kzpq0wwmz2ilcvghh";
+ };
+ autoqemu = default-derivation {
+ pname = "autoqemu";
+ version-prefix = "";
+ version = "5c44e0d0fa46ccd35c28e48849fcd5153fe41e5a";
+ sha256 = "0izyp4ck618c10hr0n3365xdfgnp8vd3pwz147hanh0h3f0wmnj9";
+ };
+ };
+}