aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2020-02-06 12:21:23 -0300
committerEuAndreh <eu@euandre.org>2020-02-06 12:21:23 -0300
commitd11737846ed46d4b9ba6246d81b1031d802d7b6e (patch)
tree5d6da764bd41747b16c85f008c2e6f98790bc49a /default.nix
parentTODOs.org (diff)
downloadeuandre.org-d11737846ed46d4b9ba6246d81b1031d802d7b6e.tar.gz
euandre.org-d11737846ed46d4b9ba6246d81b1031d802d7b6e.tar.xz
Run assert-content.sh in test derivation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 5f6663d..c664429 100644
--- a/default.nix
+++ b/default.nix
@@ -22,6 +22,15 @@ in rec {
touch $out
'';
});
+ assertContent = utils.baseTask.overrideAttrs (baseAttrs: {
+ name = "${baseAttrs.name}-assert-content";
+ buildInputs = baseAttrs.buildInputs ++ [ pkgs.jq ];
+ buildPhase = ''
+ patchShebangs .
+ ./scripts/assert-content.sh "${subtasks.docs}/site.json"
+ touch $out
+ '';
+ });
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
buildInputs = [ jekyllEnv ];
@@ -35,6 +44,7 @@ in rec {
(utils.shellcheck null)
(utils.fixme null)
subtasks.hunspellCheck
+ subtasks.assertContent
];
shell = pkgs.mkShell rec {
name = "website-shell";