aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2020-02-05 16:23:08 -0300
committerEuAndreh <eu@euandre.org>2020-02-05 16:23:08 -0300
commit847789edcf135f38b27f8f6ac3a85386037e4e38 (patch)
tree1dc86f4eb6894642d503d93530717773b3815b8b /default.nix
parentRemove spelling/ (diff)
downloadeuandre.org-847789edcf135f38b27f8f6ac3a85386037e4e38.tar.gz
euandre.org-847789edcf135f38b27f8f6ac3a85386037e4e38.tar.xz
Add manual support for multiple languages
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix24
1 files changed, 3 insertions, 21 deletions
diff --git a/default.nix b/default.nix
index 78d2ce9..e79da46 100644
--- a/default.nix
+++ b/default.nix
@@ -13,37 +13,19 @@ in rec {
gemset = ./gemset.nix;
};
subtasks = rec {
- hunspellCheck = utils.baseTask.overrideAttrs (baseAttrs: {
- name = "${baseAttrs.name}-hunspell";
- buildInputs = baseAttrs.buildInputs
- ++ [ (pkgs.hunspellWithDicts (with pkgs.hunspellDicts; [ en-us ])) ];
- buildPhase = ''
- patchShebangs .
- ./spelling/check-spelling.sh "${subtasks.docs}"
- touch $out
- '';
- });
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
- src = ./site;
- buildInputs = [ ];
+ buildInputs = [ jekyllEnv ];
buildPhase = ''
- export LOCALE_ARCHIVE="${pkgs.glibcLocales}/lib/locale/locale-archive";
- export LANG=en_US.UTF-8
- build-site build
mkdir $out
- cp -r _site/* $out
+ jekyll build -d $out
'';
});
};
test = utils.test [
utils.formatNix
(utils.shellcheck null)
- (utils.fixme [ "pastebin/skeleton.org" "utils.nix" ])
- subtasks.perlPodCheck
- subtasks.batsTest
- subtasks.perlInternalTest
- subtasks.hunspellCheck
+ (utils.fixme null)
];
shell = pkgs.mkShell rec {
name = "website-shell";