aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2020-02-12 09:26:16 -0300
committerEuAndreh <eu@euandre.org>2020-02-12 09:26:16 -0300
commit381ac1fc3d98ecd0b6f5215c54f907eac6d2b873 (patch)
tree1f1cd3dfbcc09dd6712e0a57e8e1ea458bd51274 /default.nix
parentSort pastebins listing by date (diff)
downloadeuandre.org-381ac1fc3d98ecd0b6f5215c54f907eac6d2b873.tar.gz
euandre.org-381ac1fc3d98ecd0b6f5215c54f907eac6d2b873.tar.xz
html tidy wip
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index c664429..0f98063 100644
--- a/default.nix
+++ b/default.nix
@@ -33,9 +33,10 @@ in rec {
});
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
- buildInputs = [ jekyllEnv ];
+ buildInputs = [ jekyllEnv pkgs.html-tidy ];
buildPhase = ''
jekyll build -d $out
+ find $out -type f -name '*.html' | xargs -I{} tidy -errors -utf8 -indent -modify {}
'';
});
};
@@ -51,6 +52,7 @@ in rec {
buildInputs = [
jekyllEnv
(pkgs.hunspellWithDicts (with pkgs.hunspellDicts; [ en-us ]))
+ pkgs.html-tidy
];
};
publishScript = utils.overwritingPublishScript {