aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..8481db4
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,32 @@
+let
+ pkgs = import <nixpkgs> {};
+in with pkgs; with pkgs.stdenv; rec {
+ subtasks = rec {
+ shellcheck = mkDerivation rec {
+ name = "dotfiles-shellcheck";
+ src = ./.;
+ phases = "unpackPhase buildPhase";
+ buildInputs = [ pkgs.shellcheck ];
+ buildPhase = ''
+ find . -type f -name '*.sh' | xargs shellcheck
+ touch $out
+ '';
+ };
+ };
+ test = mkDerivation rec {
+ name = "dotfiles-test";
+ src = ./.;
+ phases = "unpackPhase buildPhase";
+ buildInputs = [
+ subtasks.shellcheck
+ ];
+ buildPhase = ''
+ echo "Ran tests for:"
+ for d in ${builtins.toString buildInputs}; do
+ echo " $d"
+ done
+ echo "All tests passed!"
+ touch $out
+ '';
+ };
+}