aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 298d1af..c27faff 100644
--- a/default.nix
+++ b/default.nix
@@ -8,7 +8,9 @@ in with pkgs; with pkgs.stdenv; rec {
phases = "unpackPhase buildPhase";
buildInputs = [ pkgs.shellcheck ];
buildPhase = ''
- find . -type f -name '*.sh' | grep -v os-installation.sh | xargs shellcheck -e SC1090 -e SC1091 -e SC2139
+ export SHELLCHECK_OPTS="-e SC1090 -e SC1091 -e SC2139"
+ ignored='(encrypted|os-installation.sh|notmuch-post.sh)'
+ find . -type f -name '*.sh' | grep -E -v $ignored | xargs shellcheck
touch $out
'';
};