aboutsummaryrefslogtreecommitdiff
path: root/nixos/utils.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2019-05-31 06:57:33 -0300
committerEuAndreh <eu@euandre.org>2019-05-31 06:57:33 -0300
commitcecc9511bfa7c7173b9375a38d82225a0bd20209 (patch)
treeb4ec1fb615903cd8d7f0a1e888992c4ec2ca12ac /nixos/utils.nix
parentUse nix-shell shebang for public/install-nixos.sh (diff)
downloaddotfiles-cecc9511bfa7c7173b9375a38d82225a0bd20209.tar.gz
dotfiles-cecc9511bfa7c7173b9375a38d82225a0bd20209.tar.xz
Format Nix files (linter offense)
Diffstat (limited to 'nixos/utils.nix')
-rw-r--r--nixos/utils.nix27
1 files changed, 14 insertions, 13 deletions
diff --git a/nixos/utils.nix b/nixos/utils.nix
index e1a339a..704dd56 100644
--- a/nixos/utils.nix
+++ b/nixos/utils.nix
@@ -58,22 +58,23 @@ in rec {
exit 1
'';
});
- orgMkDocs = title: baseTask.overrideAttrs (baseAttrs: {
- name = "${baseAttrs.name}-docs";
- buildInputs = [pkgs.pandoc pkgs.mkdocs];
- buildPhase = ''
- # Convert from org-mode to markdown with pandoc
- find docs/ -type f -name '*.org' -print0 | xargs -0 -I{} pandoc -o {}.md {}.org
+ orgMkDocs = title:
+ baseTask.overrideAttrs (baseAttrs: {
+ name = "${baseAttrs.name}-docs";
+ buildInputs = [ pkgs.pandoc pkgs.mkdocs ];
+ buildPhase = ''
+ # Convert from org-mode to markdown with pandoc
+ find docs/ -type f -name '*.org' -print0 | xargs -0 -I{} pandoc -o {}.md {}.org
- # Give the generated markdown files to MkDocs
- mkdocs build
+ # Give the generated markdown files to MkDocs
+ mkdocs build
- # Build remaining one-off files
- pandoc README.org -o site/index.html --css docs/README.css --to=html5 --self-contained --metadata title="${title}"
+ # Build remaining one-off files
+ pandoc README.org -o site/index.html --css docs/README.css --to=html5 --self-contained --metadata title="${title}"
- mv site/ $out/
- '';
- });
+ mv site/ $out/
+ '';
+ });
test = testDerivations:
baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-test";