aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix60
1 files changed, 33 insertions, 27 deletions
diff --git a/default.nix b/default.nix
index 3732bae..7bdba4d 100644
--- a/default.nix
+++ b/default.nix
@@ -1,37 +1,43 @@
{ pkgs }:
-self: super:
-let
- default-derivation = { name, version-prefix, version, check-inputs, ... }:
- pkgs.stdenv.mkDerivation rec {
- inherit name version;
+self: super: {
+ xyz-euandreh = {
+ remembering = pkgs.stdenv.mkDerivation rec {
+ name = "remembering";
+ version = "cca66c6f53e8bce857faae88368c0b07e6ace9e1";
+
+ src = fetchTarball {
+ url =
+ "https://git.euandreh.xyz/${name}/snapshot/${name}-${version}.tar.gz";
+ sha256 = "0bpm73hvpk6x3vs2lkp0kjnfdyb5hq3spl0kzpq0wwmz2ilcvghh";
+ };
- checkInputs = map (p: pkgs."${p}") check-inputs;
doCheck = true;
+ };
+
+ autoqemu = pkgs.stdenv.mkDerivation rec {
+ name = "autoqemu";
+ version = "9aff342b2179f990a7c63ee5c7569260a8498709";
src = fetchTarball {
url =
- "https://git.euandreh.xyz/${name}/snapshot/${name}-${version-prefix}${version}.tar.gz";
+ "https://git.euandreh.xyz/${name}/snapshot/${name}-${version}.tar.gz";
+ sha256 = "0izyp4ck618c10hr0n3365xdfgnp8vd3pwz147hanh0h3f0wmnj9";
};
- makeFlags = [
- # This shouldn't be necessary, but
- # the `stdenv.mkDerivation' environment doesn't provide a c99 variable
- "CC=cc"
- ];
-
- meta = with pkgs.lib; {
- description = readFile "${src}/description";
- longDescription = readFile "${src}/long-description";
- homepage = "https://${name}.euandreh.xyz";
- changelog = "https://${name}.euandreh.xyz/CHANGELOG.html";
- downloadPage = "https://${name}.euandreh.xyz/#releases";
- license = licenses.agpl3;
- platforms = platforms.unix;
+
+ doCheck = true;
+ };
+
+ fallible = pkgs.stdenv.mkDerivation rec {
+ name = "fallible";
+ version = "2bac4b52f756fce15a4758a3b868bed9de87ff49";
+
+ src = fetchTarball {
+ url =
+ "https://git.euandreh.xyz/${name}/snapshot/${name}-${version}.tar.gz";
+ sha256 = "0bpm73hvpk6x3vs2lkp0kjnfdyb5hq3spl0kzpq0wwmz2ilcvghh";
};
+
+ doCheck = true;
};
-in {
- xyz-euandreh = pkgs.lib.fold ({ name, ... }@project:
- acc:
- acc // {
- "${name}" = default-derivation project;
- }) { } (builtins.fromJSON (builtins.readFile ./packages.json)).packages;
+ };
}