aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix27
1 files changed, 17 insertions, 10 deletions
diff --git a/default.nix b/default.nix
index a361043..016f4d6 100644
--- a/default.nix
+++ b/default.nix
@@ -1,26 +1,33 @@
{ pkgs }:
self: super: {
- xyz-euandreh = {
- td-latest = pkgs.stdenv.mkDerivation rec {
- name = "td";
- version = "7a1d07c1051ff48f17c915f99e20b629ed0a6a70";
+ org-euandre = {
+ guile-heredoc-latest = pkgs.stdenv.mkDerivation rec {
+ name = "guile-heredoc";
+ version = "065435cdce609604e33b879b9be3e81ab89f3e7b";
src = fetchTarball {
url =
- "https://euandreh.xyz/${name}.git/snapshot/${name}-${version}.tar.gz";
- sha256 = "0nfawz4bs5rihgz7943z3w4izxb4isx8k2ixkzv8977f1v3swj6j";
+ "https://euandre.org/git/${name}/snapshot/${name}-${version}.tar.gz";
+ sha256 = "179qq17mgi4kakhj9w1dk26afljh5yad4j9ih9d8wms70x6h211m";
};
+ nativeBuildInputs = with pkgs; [
+ texinfo
+ ];
+ buildInputs = with pkgs; [
+ guile
+ ];
makeFlags = [ "PREFIX=$(out)" ];
doCheck = true;
+ enableParallelBuilding = true;
meta = with pkgs.lib; {
- description = readFile "${src}/description";
+ description = readFile "${src}/description"; # FIXME
longDescription = readFile "${src}/long-description";
- homepage = "https://euandreh.xyz/td/";
- changelog = "https://euandreh.xyz/td/CHANGELOG.html";
- downloadPage = "https://euandreh.xyz/td/#releases";
+ homepage = "https://euandre.org/projects/guile-heredoc/";
+ changelog = "https://euandre.org/projects/guile-heredoc/CHANGELOG.html";
+ downloadPage = "https://euandre.org/projects/guile-heredoc/#releases";
license = licenses.agpl3;
platforms = platforms.unix;
};