aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-01-19 09:45:38 -0300
committerEuAndreh <eu@euandre.org>2022-01-19 09:45:38 -0300
commit67946ea95ad4f57fe9ebaa411f3800f5db3461f2 (patch)
treedb5b270aca2af0da7b018b1e307198da754e91da /default.nix
parentUpdate left-over references to git.euandreh.xyz (diff)
downloadpackage-repository-67946ea95ad4f57fe9ebaa411f3800f5db3461f2.tar.gz
package-repository-67946ea95ad4f57fe9ebaa411f3800f5db3461f2.tar.xz
paku.json: Archive WIP packages
Diffstat (limited to '')
-rw-r--r--default.nix73
1 files changed, 1 insertions, 72 deletions
diff --git a/default.nix b/default.nix
index f9af6c7..10b2b39 100644
--- a/default.nix
+++ b/default.nix
@@ -13,78 +13,7 @@ self: super: {
makeFlags = [ "CC=cc" "PREFIX=$(out)" ];
- doCheck = true;
-
- meta = with pkgs.lib; {
- description = readFile "${src}/description";
- longDescription = readFile "${src}/long-description";
- homepage = "https://${name}.euandreh.xyz";
- changelog = "https://${name}.euandreh.xyz/CHANGELOG.html";
- downloadPage = "https://${name}.euandreh.xyz/#releases";
- license = licenses.agpl3;
- platforms = platforms.unix;
- };
- };
- remembering = pkgs.stdenv.mkDerivation rec {
- name = "remembering";
- version = "0.2.1";
-
- src = fetchTarball {
- url =
- "https://euandreh.xyz/${name}.git/snapshot/${name}-${version}.tar.gz";
- sha256 = "15lxlhxllgmw1ampf36g4sr1gfd6vr257l4jw0z5457z2jvis9yg";
- };
-
- makeFlags = [ "CC=cc" "PREFIX=$(out)" ];
-
- doCheck = true;
-
- meta = with pkgs.lib; {
- description = readFile "${src}/description";
- longDescription = readFile "${src}/long-description";
- homepage = "https://${name}.euandreh.xyz";
- changelog = "https://${name}.euandreh.xyz/CHANGELOG.html";
- downloadPage = "https://${name}.euandreh.xyz/#releases";
- license = licenses.agpl3;
- platforms = platforms.unix;
- };
- };
- git-permalink-latest = pkgs.stdenv.mkDerivation rec {
- name = "git-permalink";
- version = "7f0c97b64bcccbdcd1667f2c2ca8f1face9ca027";
-
- src = fetchTarball {
- url =
- "https://euandreh.xyz/${name}.git/snapshot/${name}-${version}.tar.gz";
- sha256 = "1s9gbq0k5wpn0rjp1a9kzjh6sy7bbbqghykb7k4nms3wl0prip67";
- };
-
- makeFlags = [ "CC=cc" "PREFIX=$(out)" ];
-
- doCheck = true;
-
- meta = with pkgs.lib; {
- description = readFile "${src}/description";
- longDescription = readFile "${src}/long-description";
- homepage = "https://${name}.euandreh.xyz";
- changelog = "https://${name}.euandreh.xyz/CHANGELOG.html";
- downloadPage = "https://${name}.euandreh.xyz/#releases";
- license = licenses.agpl3;
- platforms = platforms.unix;
- };
- };
- git-permalink = pkgs.stdenv.mkDerivation rec {
- name = "git-permalink";
- version = "0.3.1";
-
- src = fetchTarball {
- url =
- "https://euandreh.xyz/${name}.git/snapshot/${name}-${version}.tar.gz";
- sha256 = "0agymhi7c75mn0glr3fg94grn1mmp2mk8ph2cwr0zf8pzyx0imcn";
- };
-
- makeFlags = [ "CC=cc" "PREFIX=$(out)" ];
-
+ checkInputs = with pkgs; [ m4 ];
doCheck = true;
meta = with pkgs.lib; {