aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2023-03-20 14:37:34 -0300
committerEuAndreh <eu@euandre.org>2023-03-21 07:34:35 -0300
commit58167062f674cbc5ac97991a921a1ac92118101c (patch)
treed39312ce189e459a46b0d1d41ffedf1e1c1063fa /default.nix
parentqueue.scm: Remove (mail-in-home? ...) option from Postfix and Dovecot (diff)
downloadpackage-repository-58167062f674cbc5ac97991a921a1ac92118101c.tar.gz
package-repository-58167062f674cbc5ac97991a921a1ac92118101c.tar.xz
Big revamp of paku(1): now in Perl, genating Debian packages
Diffstat (limited to '')
-rw-r--r--default.nix160
1 files changed, 153 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 016f4d6..54dd0ff 100644
--- a/default.nix
+++ b/default.nix
@@ -1,33 +1,179 @@
{ pkgs }:
self: super: {
- org-euandre = {
+ org-euandre = rec {
+ git-permalink-0-1-0 = pkgs.stdenv.mkDerivation rec {
+ name = "git-permalink";
+ version = "v0.1.0";
+
+ src = fetchTarball {
+ url =
+ "https://euandre.org/git/git-permalink/snapshot/git-permalink-v0.1.0.tar.xz";
+ sha256 = "1jb0rgcj5b4bkm5gds3l0dymf3gd644r2njmirs9345vf54if45y";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ ];
+
+ buildInputs = with pkgs; [
+ ];
+
+ makeFlags = [ "PREFIX=$(out)" ];
+
+ doCheck = true;
+ enableParallelBuilding = true;
+
+ meta = with pkgs.lib; {
+ description = "Git extension to generate web permalinks of files in a repository";
+ longDescription = ''
+ It knows about many of the existing code forges, but allows for URL
+ template overrides to be used on custom domains or deployments via git
+ config.
+ '';
+ homepage = "https://euandre.org/s/git-permalink/";
+ changelog = "https://euandre.org/s/git-permalink/CHANGELOG.html";
+ downloadPage = "https://euandre.org/s/git-permalink/#releases";
+ license = licenses.agpl3;
+ platforms = platforms.unix;
+ };
+ };
+ git-permalink-0-2-0 = pkgs.stdenv.mkDerivation rec {
+ name = "git-permalink";
+ version = "v0.2.0";
+
+ src = fetchTarball {
+ url =
+ "https://euandre.org/git/git-permalink/snapshot/git-permalink-v0.2.0.tar.xz";
+ sha256 = "1bzx4gdfc87jfshaqifxpc3llp2j98wkzjjslzwbrqn59jzakxc9";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ ];
+
+ buildInputs = with pkgs; [
+ ];
+
+ makeFlags = [ "PREFIX=$(out)" ];
+
+ doCheck = true;
+ enableParallelBuilding = true;
+
+ meta = with pkgs.lib; {
+ description = "Git extension to generate web permalinks of files in a repository";
+ longDescription = ''
+ It knows about many of the existing code forges, but allows for URL
+ template overrides to be used on custom domains or deployments via git
+ config.
+ '';
+ homepage = "https://euandre.org/s/git-permalink/";
+ changelog = "https://euandre.org/s/git-permalink/CHANGELOG.html";
+ downloadPage = "https://euandre.org/s/git-permalink/#releases";
+ license = licenses.agpl3;
+ platforms = platforms.unix;
+ };
+ };
+ remembering-0-1-2 = pkgs.stdenv.mkDerivation rec {
+ name = "remembering";
+ version = "v0.1.2";
+
+ src = fetchTarball {
+ url =
+ "https://euandre.org/git/remembering/snapshot/remembering-v0.1.2.tar.xz";
+ sha256 = "1mrkyfcgz77hw7mpgqrnsaws9qng2awf8flslzf1s1gikk3zljns";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ ];
+
+ buildInputs = with pkgs; [
+ ];
+
+ makeFlags = [ "PREFIX=$(out)" ];
+
+ doCheck = true;
+ enableParallelBuilding = true;
+
+ meta = with pkgs.lib; {
+ description = "Add memory to dmenu, fzf and similar tools";
+ longDescription = ''
+ It can wrap such tools to accumulate preferences over time, and
+ re-arrange the input according to common picks.
+ '';
+ homepage = "https://euandre.org/s/remembering/";
+ changelog = "https://euandre.org/s/remembering/CHANGELOG.html";
+ downloadPage = "https://euandre.org/s/remembering/#releases";
+ license = licenses.agpl3;
+ platforms = platforms.unix;
+ };
+ };
+ td = td-latest;
+ td-latest = pkgs.stdenv.mkDerivation rec {
+ name = "td";
+ version = "4a8a7a2662c94b2581f587e9a4b81feba4f5e7d8";
+
+ src = fetchTarball {
+ url =
+ "https://euandre.org/git/td/snapshot/td-4a8a7a2662c94b2581f587e9a4b81feba4f5e7d8.tar.xz";
+ sha256 = "1xqr2vc270jydk508pbkhcchmbg74w4bf83ch2d85nqja14r64n9";
+ };
+
+ nativeBuildInputs = with pkgs; [
+ ];
+
+ buildInputs = with pkgs; [
+ ];
+
+ makeFlags = [ "PREFIX=$(out)" ];
+
+ doCheck = true;
+ enableParallelBuilding = true;
+
+ meta = with pkgs.lib; {
+ description = "Minimalistic bug tracker CLI";
+ longDescription = ''
+ Create and maintain a TODOs.md files as a bug database.
+
+ It is a tool for distributed, offline issue tracking, reified as a simple text
+ file in the repository.
+ '';
+ homepage = "https://euandre.org/s/td/";
+ changelog = "https://euandre.org/s/td/CHANGELOG.html";
+ downloadPage = "https://euandre.org/s/td/#releases";
+ license = licenses.agpl3;
+ platforms = platforms.unix;
+ };
+ };
+ guile-heredoc = guile-heredoc-latest;
guile-heredoc-latest = pkgs.stdenv.mkDerivation rec {
name = "guile-heredoc";
version = "065435cdce609604e33b879b9be3e81ab89f3e7b";
src = fetchTarball {
url =
- "https://euandre.org/git/${name}/snapshot/${name}-${version}.tar.gz";
+ "https://euandre.org/git/guile-heredoc/snapshot/guile-heredoc-065435cdce609604e33b879b9be3e81ab89f3e7b.tar.xz";
sha256 = "179qq17mgi4kakhj9w1dk26afljh5yad4j9ih9d8wms70x6h211m";
};
nativeBuildInputs = with pkgs; [
texinfo
];
+
buildInputs = with pkgs; [
guile
];
+
makeFlags = [ "PREFIX=$(out)" ];
doCheck = true;
enableParallelBuilding = true;
meta = with pkgs.lib; {
- description = readFile "${src}/description"; # FIXME
- longDescription = readFile "${src}/long-description";
- homepage = "https://euandre.org/projects/guile-heredoc/";
- changelog = "https://euandre.org/projects/guile-heredoc/CHANGELOG.html";
- downloadPage = "https://euandre.org/projects/guile-heredoc/#releases";
+ description = "Guile heredoc syntax";
+ longDescription = ''
+ Guile heredoc syntax long.
+ '';
+ homepage = "https://euandre.org/s/guile-heredoc/";
+ changelog = "https://euandre.org/s/guile-heredoc/CHANGELOG.html";
+ downloadPage = "https://euandre.org/s/guile-heredoc/#releases";
license = licenses.agpl3;
platforms = platforms.unix;
};