aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index bb83afc..801c50d 100644
--- a/default.nix
+++ b/default.nix
@@ -12,9 +12,19 @@ let
gemset = ./nix/gemset.nix;
};
+ mktorrent-newer = pkgs.mktorrent.overrideAttrs(oldAttrs: {
+ src = pkgs.fetchFromGitHub {
+ owner = "Rudde";
+ repo = "mktorrent";
+ rev = "ea1fbf29d19f34a93f7d984c1ac29d6d08f1f508";
+ sha256 = "1cjq96qridpvqhphj3ljnhysnqkdck415wxaqy768r0rvzqq1ja4";
+ };
+ });
+
projectBuildInputs = with pkgs; [
jekyllEnv
pkgs-next.mdpo
+ mktorrent-newer
perl
graphviz
@@ -39,7 +49,7 @@ in rec {
test = pkgs.stdenv.mkDerivation {
inherit src;
name = "website-test";
- phases = [ "unpackPhase" "buildPhase" ];
+ phases = projectBuildInputs;
buildInputs = projectBuildInputs;
buildPhase = ''
patchShebangs .