aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index c664429..2f10691 100644
--- a/default.nix
+++ b/default.nix
@@ -33,9 +33,15 @@ in rec {
});
docs = utils.baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-docs";
- buildInputs = [ jekyllEnv ];
+ buildInputs = [ jekyllEnv pkgs.html-tidy ];
buildPhase = ''
+ patchShebangs .
jekyll build -d $out
+ ./scripts/tidy-content.sh $out || {
+ echo 'Error in formatting HTML. Reproduce with: '
+ echo ' jekyll build && ./scripts/tidy-content.sh _site/'
+ exit 1
+ }
'';
});
};
@@ -45,12 +51,14 @@ in rec {
(utils.fixme null)
subtasks.hunspellCheck
subtasks.assertContent
+ subtasks.docs
];
shell = pkgs.mkShell rec {
name = "website-shell";
buildInputs = [
jekyllEnv
(pkgs.hunspellWithDicts (with pkgs.hunspellDicts; [ en-us ]))
+ pkgs.html-tidy
];
};
publishScript = utils.overwritingPublishScript {