aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index fc84d6e..e36a40f 100644
--- a/default.nix
+++ b/default.nix
@@ -61,15 +61,16 @@ in rec {
echo 'Starting a live server with:'
echo ' jekyll serve --future --livereload --trace'
echo 'Server with feature flags:'
- echo ' jekyll serve --future --livereload --trace -c $(cfg podcast screencast)'
+ echo ' jekyll serve --future --livereload --trace -c $(cfg podcast screencast direct-video)'
export JEKYLL_ENV=production
cfg() {
T="$(mktemp --suffix .yml)"
cp _config.yml "$T"
+ printf 'flags:' >> "$T"
for flag in "$@"; do
- printf '\n%s: true\n' "$flag" >> "$T"
+ printf '\n %s: true' "$flag" >> "$T"
done
echo "$T"
}