aboutsummaryrefslogtreecommitdiff
path: root/utils.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2019-06-04 05:55:00 -0300
committerEuAndreh <eu@euandre.org>2019-06-04 05:55:00 -0300
commit90c531a097c8187fd9fa65a4444203d9e01d3309 (patch)
tree4624462c870bac9eb421800286ef8d5a914a565d /utils.nix
parentWIP: add draft on programming phoenix review (diff)
downloadeuandre.org-90c531a097c8187fd9fa65a4444203d9e01d3309.tar.gz
euandre.org-90c531a097c8187fd9fa65a4444203d9e01d3309.tar.xz
Use -x flag for shellcheck in utils.nix
Diffstat (limited to '')
-rw-r--r--utils.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils.nix b/utils.nix
index 6870cba..326966a 100644
--- a/utils.nix
+++ b/utils.nix
@@ -20,7 +20,7 @@ in rec {
ignoredPattern =
if ignoredFindPattern == null then "" else ignoredFindPattern;
buildPhase = ''
- find . -type f \( -name '*.sh' -and -regextype egrep ! -regex '${ignoredPattern}' \) -print0 | xargs -0 shellcheck
+ find . -type f \( -name '*.sh' -and -regextype egrep ! -regex '${ignoredPattern}' \) -print0 | xargs -0 shellcheck -x
touch $out
'';
});