aboutsummaryrefslogtreecommitdiff
path: root/utils.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2019-06-02 16:17:49 -0300
committerEuAndreh <eu@euandre.org>2019-06-02 16:17:49 -0300
commit6d9cd139c4eb5da4592a0805c528061c7bbc4416 (patch)
tree3f2d53912cd4e859dfa6e8edfc8d7e595550aff8 /utils.nix
parentUpdate utils.nix (diff)
downloadeuandre.org-6d9cd139c4eb5da4592a0805c528061c7bbc4416.tar.gz
euandre.org-6d9cd139c4eb5da4592a0805c528061c7bbc4416.tar.xz
Update utils.nix to now use local README.css file
Diffstat (limited to '')
-rw-r--r--utils.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/utils.nix b/utils.nix
index 2c1a9d3..6870cba 100644
--- a/utils.nix
+++ b/utils.nix
@@ -61,16 +61,12 @@ in rec {
exit 1
'';
});
- readmeCss = builtins.fetchurl {
- url = "https://euandre.org/dotfiles/static/README.css";
- sha256 = "1r7ak92zsbhjm1qxz0r3dig0yxb41l43zl0yai63izha2s5r54d4";
- };
readmeOrg = title:
baseTask.overrideAttrs (baseAttrs: {
name = "${baseAttrs.name}-readme-docs";
buildInputs = [ pkgs.pandoc ];
buildPhase = ''
- pandoc README.org -o $out --css ${readmeCss} --to=html5 --self-contained --metadata title="${title}"
+ pandoc README.org -o $out --css docs/README.css --to=html5 --self-contained --metadata title="${title}"
'';
});
test = testDerivations: