aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2018-12-30 07:55:39 -0200
committerEuAndreh <eu@euandre.org>2018-12-30 08:07:18 -0200
commitf8a472971bd600ad23d8846b1105e275268a3d8b (patch)
treedbbaa117a337d80c06c795e5536bf09687390275 /default.nix
parentUse creation date of pastebin instead of dynamic exported date. (diff)
downloadeuandre.org-f8a472971bd600ad23d8846b1105e275268a3d8b.tar.gz
euandre.org-f8a472971bd600ad23d8846b1105e275268a3d8b.tar.xz
Generate pastebin HTML with pandoc.
Instead of generating the HTML manually inside Emacs (=, e e h h=) and than commiting the file to the repo, we now use a more generic approach with pandoc, not tied to any Elisp configuration.
Diffstat (limited to '')
-rw-r--r--default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index d49da29..6c8a56c 100644
--- a/default.nix
+++ b/default.nix
@@ -24,10 +24,13 @@ in with pkgs; with pkgs.stdenv; rec {
name = "website";
src = ./site;
phases = "unpackPhase buildPhase";
- buildInputs = [ websiteBuilder ];
+ buildInputs = [ websiteBuilder pandoc ];
buildPhase = ''
export LOCALE_ARCHIVE="${pkgs.glibcLocales}/lib/locale/locale-archive";
export LANG=en_US.UTF-8
+
+ ls pastebin/*.org | awk -F. '{print $1}' | xargs -I{} pandoc -o {}.html {}.org --standalone
+
build-site build
mkdir $out