aboutsummaryrefslogtreecommitdiff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix71
1 files changed, 58 insertions, 13 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index ba986e4..f5b38b3 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -73,12 +73,23 @@
url = "https://github.com/NixOS/nixpkgs/archive/18.03.zip";
sha256 = "0hk4y2vkgm1qadpsm4b0q1vxq889jhxzjx3ragybrlwwg54mzp4f";
}) {};
+
timidityWithEvenMoreFormats = with pkgs; timidity.overrideAttrs (oldAttrs: {
configureFlags = oldAttrs.configureFlags ++ [ "--enable-audio=vorbis,flac" ];
buildInputs = oldAttrs.buildInputs ++ [ libogg libvorbis flac ];
});
+
+ # https://github.com/nixos/nixpkgs/blob/0d202221f98e500f1df79112dc464d013eefcdae/pkgs/development/web/nodejs/v10.nix#L4
+ buildNodejs = pkgs.callPackage <nixpkgs/pkgs/development/web/nodejs/nodejs.nix> {};
+ nodejs-10_14_1 = buildNodejs {
+ enableNpm = true;
+ version = "10.14.1";
+ sha256 = "0d5hg8hf4c1sshh77a6hy944bzm3q3ipqggbyim61q3r2szngvrx";
+ # Uses HTTPS (https://github.com/nixos/nixpkgs/blob/0d202221f98e500f1df79112dc464d013eefcdae/pkgs/development/web/nodejs/nodejs.nix#L45), safer to trust the hash (unless it's already compromised :shrug:)
+ };
in with pkgs; [
- pkgsUnstable.nodejs-10_x
+ pkgsUnstable.nodejs-10_x
+ # nodejs-10_14_1
## Personal data tools
@@ -94,6 +105,7 @@
gnupg
mr
nextcloud-client
+ owncloud-client
borgbackup
git-sizer
@@ -159,6 +171,7 @@
gitlab-runner
sshpass
zathura # for viewing Emacs PDF files
+ nvi
cacert
gtypist
pandoc
@@ -167,6 +180,10 @@
ncdu
fd
nnn
+ python36Packages.python-slugify
+ moreutils # =vipe=
+ bazel
+ graphviz # =dot= and others
diffoscope #
poppler_utils # used by diffoscope for comparing PDF files
@@ -185,6 +202,7 @@
## Spell checking
(aspellWithDicts (ps : with ps; [ en eo fr pt_BR ]))
+ languagetool
## NixOS
@@ -197,6 +215,8 @@
texlive.combined.scheme-full
lilypond
+ python36Packages.python-ly
+ lame
frescobaldi
timidityWithEvenMoreFormats
@@ -213,8 +233,7 @@
openjdk
solc
bundler
- rustc
- rustfmt
+ rustup
cargo
clojure # =clj=
visualvm # JVM profiling tool
@@ -224,7 +243,16 @@
rakudo
bats
ledger
-
+ newsboat
+ perl
+ dhall
+ dhall-json
+ nodePackages.node2nix
+ shellcheck
+ (haskell.lib.justStaticExecutables haskellPackages.github-backup)
+ rustracer
+ xsel
+ buku
## Containers and VMs
@@ -256,7 +284,9 @@
## GUI programs
+ inkscape
calibre
+ pkgsUnstable.cozy
rhythmbox
gpodder
firefox
@@ -265,13 +295,14 @@
vlc
keepassx2-http
yubioath-desktop
- tor-browser-bundle-bin
+ # tor-browser-bundle-bin
transmission_gtk
libreoffice
android-studio
androidsdk_extras
androidndk
pkgsUnstable.patchwork-classic
+ # gnome3.gpaste
## Cryptocururencies
@@ -283,11 +314,16 @@
## nu specific packages
+ sshuttle
slack
chromium
];
- nixpkgs.config.allowUnfree = true; # Require for slack (unfree) derivation
+ nixpkgs.config = {
+ android_sdk.accept_license = true;
+ allowUnfree = true; # Require for slack (unfree) derivation
+ };
+
# Look at
# https://www.vivaolinux.com.br/topico/Off-Code-Cafe/Me-apresente-sua-distro
@@ -299,7 +335,16 @@
services = {
cron.enable = true;
# We can see the actual generated crontab at /etc/crontab
- cron.systemCronJobs = ["0 * * * * andreh /home/andreh/annex/dev/code/dotfiles/scripts/mail.sh -s"];
+ cron.systemCronJobs = [
+ # Sync emails with mbsync every hour
+ "0 * * * * andreh /home/andreh/dev/libre/dotfiles/scripts/mail.sh -s"
+
+ # Refresh local RSS files every hour
+ "0 * * * * andreh /home/andreh/dev/libre/dotfiles/scripts/atom.sh"
+
+ # Make read-only copy of TODOs.org every hour
+ # "0 * * * * andreh /home/andreh/dev/libre/dotfiles/scripts/cp-todos.sh -s"
+ ];
xserver = {
enable = true;
@@ -327,7 +372,7 @@
# xmodmap -e 'keycode 118 = bar Greek_lamda'
sessionCommands = ''
${pkgs.haskellPackages.xmobar}/bin/xmobar ~/.xmobarrc &
- ${pkgs.fvwm}/bin/xpmroot ~/Nextcloud/Images/emotion.png &
+ ${pkgs.fvwm}/bin/xpmroot ~/ownCloud/Images/emotion.png &
'';
};
};
@@ -336,7 +381,7 @@
gnome-keyring.enable = true;
seahorse.enable = true;
gnome-terminal-server.enable = true;
- gpaste.enable = true; # clipboard manager
+ # gpaste.enable = true; # clipboard manager
tracker.enable = true;
sushi.enable = true; # nautilus previewer
gnome-online-accounts.enable = true;
@@ -363,9 +408,9 @@
# https://nixos.org/nixos/options.html#ipfs
ipfs = {
- enable = true;
- enableGC = true;
- autoMount = true;
+ enable = false;
+ enableGC = false;
+ autoMount = false;
};
};
@@ -386,7 +431,7 @@
uid = 1000;
description = "EuAndreh";
extraGroups = [ "wheel" "networkmanager" "docker" ];
- passwordFile = "/home/andreh/annex/dev/code/dotfiles/encrypted/password-hash.txt";
+ passwordFile = "/home/andreh/dev/libre/dotfiles/encrypted/password-hash.txt";
};
};
# From the Guix manual: