aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix30
1 files changed, 9 insertions, 21 deletions
diff --git a/default.nix b/default.nix
index 268ff9d..7b6e001 100644
--- a/default.nix
+++ b/default.nix
@@ -1,30 +1,18 @@
let
pkgs = import <nixpkgs> { };
rootSrc = pkgs.nix-gitignore.gitignoreSource [ ] ./.;
-
+in with pkgs;
+with pkgs.stdenv; rec {
utils = import ./nixos/utils.nix {
pkgs = pkgs;
rootSrc = rootSrc; # FIXME: remove the need for this
baseName = "dotfiles";
};
-in with pkgs;
-with pkgs.stdenv; rec {
- test = utils.baseTask.overrideAttrs (baseAttrs: rec {
- name = "${baseAttrs.name}-test";
- buildInputs = [
- utils.formatNix
- # subtasks.shellcheck
- # subtasks.fixme
- # subtasks.uniqueFeeds
- # subtasks.formatNix
- ];
- buildPhase = ''
- echo "Ran tests for:"
- for d in ${builtins.toString buildInputs}; do
- echo " $d"
- done
- echo "All tests passed!"
- touch $out
- '';
- });
+ test = utils.test [
+ utils.formatNix
+ (utils.shellcheck ".*(encrypted|os-installation.sh).*")
+ # subtasks.fixme
+ # subtasks.uniqueFeeds
+ # subtasks.formatNix
+ ];
}